Back to overview
Downtime
thing-it.com - degraded Admin portal performance
Aug 05 at 05:37pm CEST
Affected services
Application Services
thing-it.com - portal
Resolved
Aug 05 at 05:56pm CEST
thing-it.com - portal recovered.
Affected services
Created
Aug 05 at 05:37pm CEST
thing-it.com - degraded Admin portal performance
Affected services